summaryrefslogtreecommitdiffstats
path: root/src/vnet/CMakeLists.txt
diff options
context:
space:
mode:
authorNeale Ranns <nranns@cisco.com>2018-09-12 06:53:03 -0400
committerDamjan Marion <dmarion@me.com>2018-09-13 15:35:16 +0000
commitc25eb4547a4d25c0808a33e2a79fb7485b5bfe20 (patch)
tree9fed85b5bebdec24a9d49adc567b32598928d506 /src/vnet/CMakeLists.txt
parent008eef3073e07de3e5802215ffb213fbc198814b (diff)
L2-FWD: use vlib_buffer_enqueue_to_next and cache prefetch fix
before: l2-fwd ... 1.72e1 256.00 after: l2-fwd ... 1.49e1 256.00 Change-Id: I24b29b799435776abc6e60df0dd0301b74aac99b Signed-off-by: Neale Ranns <nranns@cisco.com>
Diffstat (limited to 'src/vnet/CMakeLists.txt')
-rw-r--r--src/vnet/CMakeLists.txt8
1 files changed, 6 insertions, 2 deletions
diff --git a/src/vnet/CMakeLists.txt b/src/vnet/CMakeLists.txt
index 9906a40fcc4..5f89b694afd 100644
--- a/src/vnet/CMakeLists.txt
+++ b/src/vnet/CMakeLists.txt
@@ -158,7 +158,11 @@ list(APPEND VNET_SOURCES
l2/l2_xcrw.c
)
-list(APPEND VNET_MULTIARCH_SOURCES l2/l2_output.c l2/l2_learn.c)
+list(APPEND VNET_MULTIARCH_SOURCES
+ l2/l2_fwd.c
+ l2/l2_learn.c
+ l2/l2_output.c
+)
list(APPEND VNET_HEADERS
l2/feat_bitmap.h
@@ -1374,4 +1378,4 @@ if(VPP_BUILD_SESSION_ECHO_APPS)
)
endif(VPP_BUILD_SESSION_ECHO_APPS)
-############################################################################## \ No newline at end of file
+##############################################################################