summaryrefslogtreecommitdiffstats
path: root/src/vpp-api/vom/Makefile.am
diff options
context:
space:
mode:
authorNeale Ranns <neale.ranns@cisco.com>2018-02-05 01:13:38 -0800
committerDamjan Marion <dmarion.lists@gmail.com>2018-02-09 13:17:54 +0000
commitbc27d1be24815e1371dcce3bff2d3075a532acba (patch)
treec17db02fefb19ce593de5ddb2444f4c97e074492 /src/vpp-api/vom/Makefile.am
parentef56fae51a8683ec6ceeb01e1374cde2ba30c1e5 (diff)
GBP plugin
Group Base Policy (GBP) defines: - endpoints: typically a VM or container that is connected to the virtual switch/router (i.e. to VPP) - endpoint-group: (EPG) a collection of endpoints - policy: rules determining which traffic can pass between EPGs a.k.a a 'contract' Here, policy is implemented via an ACL. EPG classification for transit packets is determined by: - source EPG: from the packet's input interface - destination EPG: from the packet's destination IP address. Change-Id: I7b983844826b5fc3d49e21353ebda9df9b224e25 Signed-off-by: Neale Ranns <neale.ranns@cisco.com>
Diffstat (limited to 'src/vpp-api/vom/Makefile.am')
-rw-r--r--src/vpp-api/vom/Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/src/vpp-api/vom/Makefile.am b/src/vpp-api/vom/Makefile.am
index e7e003968b0..2cb7f837571 100644
--- a/src/vpp-api/vom/Makefile.am
+++ b/src/vpp-api/vom/Makefile.am
@@ -57,6 +57,10 @@ libvom_la_SOURCES = \
connection.cpp \
dhcp_config_cmds.cpp \
dhcp_config.cpp \
+ gbp_endpoint_cmds.cpp \
+ gbp_endpoint.cpp \
+ gbp_contract_cmds.cpp \
+ gbp_contract.cpp \
hw_cmds.cpp \
hw.cpp \
inspect.cpp \
@@ -123,6 +127,8 @@ vominclude_HEADERS = \
dump_cmd.hpp \
enum_base.hpp \
event_cmd.hpp \
+ gbp_endpoint.hpp \
+ gbp_contract.hpp \
hw.hpp \
inspect.hpp \
interface.hpp \