aboutsummaryrefslogtreecommitdiffstats
path: root/src/vpp/CMakeLists.txt
diff options
context:
space:
mode:
authorDave Barach <dave@barachs.net>2019-08-14 09:35:41 -0400
committerAndrew Yourtchenko <ayourtch@gmail.com>2019-09-19 18:16:21 +0000
commit1ffabcb3df911f5f115a1c6dd51bdb5fdd3ac52c (patch)
tree46716a60634883ccd2f9017862515669478d743d /src/vpp/CMakeLists.txt
parent6b9847e8012b3b186897f3b2bdeaf478f8767301 (diff)
stats: refactor header files
Performant stat segment scraping involves caching the results of stat_segment_ls (...) and directly fishing counter data from the shared-memory segment. To do that, we need to publish several things previously hidden, declared in stat_client.c: o stat_client_main_t typedef o stat_segment_access_t typedef o stat_segment_access_start inline function o stat_segment_access_end inline function Type: refactor Signed-off-by: Dave Barach <dave@barachs.net> Change-Id: I3175e3d1f1fd8ea816336a584565179d1972115c (cherry picked from commit 531969ef614bdc15c45dae0f1b5e90afaf86eb7b)
Diffstat (limited to 'src/vpp/CMakeLists.txt')
-rw-r--r--src/vpp/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/vpp/CMakeLists.txt b/src/vpp/CMakeLists.txt
index 401f1d01190..da43b0f7a34 100644
--- a/src/vpp/CMakeLists.txt
+++ b/src/vpp/CMakeLists.txt
@@ -81,6 +81,7 @@ add_vpp_headers(vpp
api/vpe_msg_enum.h
api/vpe_all_api_h.h
stats/stat_segment.h
+ stats/stat_segment_shared.h
)
##############################################################################