aboutsummaryrefslogtreecommitdiffstats
path: root/src/vpp/CMakeLists.txt
diff options
context:
space:
mode:
authorDamjan Marion <damarion@cisco.com>2018-08-24 21:36:42 +0200
committerDamjan Marion <dmarion@me.com>2018-08-25 09:55:17 +0000
commit2bfdda76d8b1cffcd8e30ca6855f293b1b1953c5 (patch)
treed96a06e0833d4a513296ee5c8bd036f0e7f36118 /src/vpp/CMakeLists.txt
parent0219b8dfbf25090214573394cf2c9e5e968cfa9a (diff)
cmake: add more headers to the install list
Change-Id: I3a0f48381232fcac1727034aa6d2504a8d1edb04 Signed-off-by: Damjan Marion <damarion@cisco.com>
Diffstat (limited to 'src/vpp/CMakeLists.txt')
-rw-r--r--src/vpp/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/vpp/CMakeLists.txt b/src/vpp/CMakeLists.txt
index b3073deecdb..8799d26f4c8 100644
--- a/src/vpp/CMakeLists.txt
+++ b/src/vpp/CMakeLists.txt
@@ -69,6 +69,11 @@ add_dependencies(vpp vpp_version_h api_headers)
set_target_properties(vpp PROPERTIES ENABLE_EXPORTS 1)
install(TARGETS vpp DESTINATION bin)
+vpp_add_header_files(vpp
+ api/vpe_msg_enum.h
+ api/vpe_all_api_h.h
+)
+
##############################################################################
# vppctl binary
##############################################################################