aboutsummaryrefslogtreecommitdiffstats
path: root/src/vpp/CMakeLists.txt
diff options
context:
space:
mode:
authorOle Troan <ot@cisco.com>2020-09-15 10:53:34 +0200
committerDave Barach <openvpp@barachs.net>2020-09-18 15:24:52 +0000
commit3d81267945a732753b0dbd0a83a50ab0625b448a (patch)
treec00b5e6a5e798cbb29c9c450eb37d43f9303cb85 /src/vpp/CMakeLists.txt
parent34262d4d56295b0872ad4e9a4a4791953f3fa444 (diff)
vat: add infrastructure to align vnet test code and plugin test code
Split vat/api_format.c also for VNET features. Use auto-generated VAT test code and support dynamic message ID allocation as for plugins. The arp and geneve features as Guinea pigs. Type: improvement Signed-off-by: Ole Troan <ot@cisco.com> Change-Id: I461591496766bdf10c5f950fd30f1a0ae05909da Signed-off-by: Ole Troan <ot@cisco.com>
Diffstat (limited to 'src/vpp/CMakeLists.txt')
-rw-r--r--src/vpp/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/vpp/CMakeLists.txt b/src/vpp/CMakeLists.txt
index f045836bca5..64a8eb86bc6 100644
--- a/src/vpp/CMakeLists.txt
+++ b/src/vpp/CMakeLists.txt
@@ -73,6 +73,8 @@ if(VPP_API_TEST_BUILTIN)
api/api_main.c
api/plugin.c
api/types.c
+ ../vnet/arp/arp_test.c
+ ../vnet/geneve/geneve_test.c
)
add_definitions(-DVPP_API_TEST_BUILTIN=1)
endif()