aboutsummaryrefslogtreecommitdiffstats
path: root/vlib/Makefile.am
diff options
context:
space:
mode:
authorDamjan Marion <damarion@cisco.com>2016-04-13 18:03:20 +0200
committerGerrit Code Review <gerrit@fd.io>2016-04-14 23:29:13 +0000
commita42cd34f106869d5afc26f5b5db7e0cb2f73ae97 (patch)
tree0c2b31263d7d77a57db3b56dc0736a1d8ef96e07 /vlib/Makefile.am
parent550b5f62528c435e4b9d41729f1d92e8ed9e161a (diff)
Rework of DPDK PCI device uio driver binding process
This is complete rework of DPDK PCI initialization. It drops previous scheme where lspci/route/awk/sed are used and instead sysfs is solely used for discovering Ethernet PCI devices. Criteria for blacklisting device is changed from exsiting routing table entry to simple interface state obtained by SIOCGIFFLAGS ioctl(). It checks for IFF_UP flag, so as long as interface is declared up and even when carrier is down interface will be blacklisted. Change-Id: I59961ddcf1c19c728934e7fe746f343983741bf1 Signed-off-by: Damjan Marion <damarion@cisco.com>
Diffstat (limited to 'vlib/Makefile.am')
-rw-r--r--vlib/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/vlib/Makefile.am b/vlib/Makefile.am
index b38c843fc5f..17b23dfd1a8 100644
--- a/vlib/Makefile.am
+++ b/vlib/Makefile.am
@@ -65,6 +65,8 @@ nobase_include_HEADERS = \
vlib/node_funcs.h \
vlib/node.h \
vlib/physmem.h \
+ vlib/pci/pci.h \
+ vlib/pci/pci_config.h \
vlib/threads.h \
vlib/trace_funcs.h \
vlib/trace.h \
@@ -81,12 +83,14 @@ libvlib_unix_la_SOURCES = \
vlib/unix/plugin.c \
vlib/unix/plugin.h \
vlib/unix/physmem.c \
- vlib/unix/unix.h
+ vlib/unix/pci.c \
+ vlib/unix/util.c
nobase_include_HEADERS += \
vlib/unix/cj.h \
vlib/unix/mc_socket.h \
vlib/unix/physmem.h \
+ vlib/unix/pci.h \
vlib/unix/plugin.h \
vlib/unix/unix.h