summaryrefslogtreecommitdiffstats
path: root/vlib/Makefile.am
diff options
context:
space:
mode:
authorDamjan Marion <damarion@cisco.com>2016-05-12 22:11:03 +0200
committerDave Barach <openvpp@barachs.net>2016-05-18 13:13:27 +0000
commit5a206eafdbf9370fead2dd26fcab09e7ff5544c4 (patch)
tree847c6322c640fafd3a1c40e691bc8b21a7f07009 /vlib/Makefile.am
parenta2a48305df2dbcf3a930c2cd266754e2519d038e (diff)
Rework of the old PCI code
* adds support for VPP native PCI drivers using standard uio_pci_generic kernel driver * adds generic PCI interrupt callback * splits code to generic PCI handling and linux specific * adds new debug cli 'show pci [all]' Change-Id: I447c2285e319e9725d70688c1b70c9dedda51fdc Signed-off-by: Damjan Marion <damarion@cisco.com>
Diffstat (limited to 'vlib/Makefile.am')
-rw-r--r--vlib/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/vlib/Makefile.am b/vlib/Makefile.am
index 17b23dfd1a8..981c2befd5e 100644
--- a/vlib/Makefile.am
+++ b/vlib/Makefile.am
@@ -37,6 +37,8 @@ libvlib_la_SOURCES = \
vlib/node.c \
vlib/node_cli.c \
vlib/node_format.c \
+ vlib/pci/pci.c \
+ vlib/pci/linux_pci.c \
vlib/threads.c \
vlib/trace.c
@@ -83,14 +85,12 @@ libvlib_unix_la_SOURCES = \
vlib/unix/plugin.c \
vlib/unix/plugin.h \
vlib/unix/physmem.c \
- vlib/unix/pci.c \
vlib/unix/util.c
nobase_include_HEADERS += \
vlib/unix/cj.h \
vlib/unix/mc_socket.h \
vlib/unix/physmem.h \
- vlib/unix/pci.h \
vlib/unix/plugin.h \
vlib/unix/unix.h