aboutsummaryrefslogtreecommitdiffstats
path: root/vnet/Makefile.am
diff options
context:
space:
mode:
authorDamjan Marion <damarion@cisco.com>2016-02-29 13:09:30 +0100
committerDamjan Marion <damarion@cisco.com>2016-03-16 20:27:52 +0100
commit83243a0ff59f90eeed9da2da85b5bb5b3e0d5881 (patch)
treea8f2cf13bfd128a941d0dbadbb802c8eecc66aec /vnet/Makefile.am
parentb8abf877ba27098ca706281182cac67e15d7dd1e (diff)
Add vpp native linux kernel AF_PACKET interface support
This is 1st drop of VPP native driver for linux AF_PACKET. New CLI: create host-interface name <host-if-name> [hw-addr <mac-address>] References: - Documentation/networking/packet_mmap.txt in the Linux kernel tree - man 7 packet Known issues: - attaching to linux bridge doesn't work - it is not expected to work in multicore setup Change-Id: I1cb1c3d305f349759e90e76e25696718b73bd73d Signed-off-by: Damjan Marion <damarion@cisco.com>
Diffstat (limited to 'vnet/Makefile.am')
-rw-r--r--vnet/Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/vnet/Makefile.am b/vnet/Makefile.am
index cf1fb1e0ab3..ff8a31dae26 100644
--- a/vnet/Makefile.am
+++ b/vnet/Makefile.am
@@ -607,6 +607,19 @@ nobase_include_HEADERS += \
vnet/devices/ssvm/ssvm_eth.h
########################################
+# Linux packet interface
+########################################
+
+libvnet_la_SOURCES += \
+ vnet/devices/af_packet/af_packet.c \
+ vnet/devices/af_packet/device.c \
+ vnet/devices/af_packet/node.c \
+ vnet/devices/af_packet/cli.c
+
+nobase_include_HEADERS += \
+ vnet/devices/af_packet/af_packet.h
+
+########################################
# Unix kernel related
########################################