aboutsummaryrefslogtreecommitdiffstats
path: root/vnet/Makefile.am
diff options
context:
space:
mode:
authorKeith Burns (alagalah) <alagalah@gmail.com>2016-05-05 18:16:50 -0700
committerDave Barach <openvpp@barachs.net>2016-05-13 16:07:41 +0000
commit94b1442a6731bb879797c016a8febaec2f2ae7c9 (patch)
tree7c874e6fc3c102cae06133430c4b9799f073df3a /vnet/Makefile.am
parent3e53fc56645f4b99d014031995bd00d16c051a9b (diff)
VPP43 - NSH refactoring: Added nsh-map nodes
- removed vnet/vnet/nsh-gre - removed all nsh from vnet/vnet/nsh_vxlan_gpe to vnet/vnet/nsh - moved vnet/vnet/nsh_vxlan_gpe to vnet/vnet/vxlan_gpe - added cli and binary api for VXLAN GPE tunnels - plan to move vnet/vnet/nsh to new repo (sfc_nsh) and make plugin - added cli for NSH (binary API will be done in sfc_nsh) - vnet/vnet/gre will be extended in VPP-54 Change-Id: I1d27def916532321577ccd68cb982ae0d0a07e6f Signed-off-by: Keith Burns (alagalah) <alagalah@gmail.com>
Diffstat (limited to 'vnet/Makefile.am')
-rw-r--r--vnet/Makefile.am35
1 files changed, 19 insertions, 16 deletions
diff --git a/vnet/Makefile.am b/vnet/Makefile.am
index 1239a8b8df4..8a9f214ca70 100644
--- a/vnet/Makefile.am
+++ b/vnet/Makefile.am
@@ -399,37 +399,40 @@ nobase_include_HEADERS += \
########################################
# NSH Map: nsh
########################################
+ libvnet_la_SOURCES += \
+ vnet/nsh/nsh.c
-nobase_include_HEADERS += \
- vnet/nsh/nsh_packet.h \
- vnet/nsh/nsh_error.def
+ nobase_include_HEADERS += \
+ vnet/nsh/nsh_packet.h \
+ vnet/nsh/nsh.h \
+ vnet/nsh/nsh_error.def
########################################
# Tunnel protocol: nsh-gre
########################################
-libvnet_la_SOURCES += \
- vnet/nsh-gre/nsh_gre.c \
- vnet/nsh-gre/encap.c \
- vnet/nsh-gre/decap.c
+# libvnet_la_SOURCES += \
+# vnet/nsh-gre/nsh_gre.c \
+# vnet/nsh-gre/encap.c \
+# vnet/nsh-gre/decap.c
-nobase_include_HEADERS += \
- vnet/nsh-gre/nsh_gre.h
+# nobase_include_HEADERS += \
+# vnet/nsh-gre/nsh_gre.h
########################################
-# Tunnel protocol: nsh-vxlan-gpe
+# Tunnel protocol: vxlan-gpe
########################################
libvnet_la_SOURCES += \
- vnet/nsh-vxlan-gpe/nsh_vxlan_gpe.c \
- vnet/nsh-vxlan-gpe/encap.c \
- vnet/nsh-vxlan-gpe/decap.c
+ vnet/vxlan-gpe/vxlan_gpe.c \
+ vnet/vxlan-gpe/encap.c \
+ vnet/vxlan-gpe/decap.c
nobase_include_HEADERS += \
- vnet/nsh-vxlan-gpe/nsh_vxlan_gpe.h \
- vnet/nsh-vxlan-gpe/vxlan_gpe_packet.h \
- vnet/nsh-vxlan-gpe/nsh_vxlan_gpe_error.def
+ vnet/vxlan-gpe/vxlan_gpe.h \
+ vnet/vxlan-gpe/vxlan_gpe_packet.h \
+ vnet/vxlan-gpe/vxlan_gpe_error.def
########################################
# LISP control plane: lisp-cp