aboutsummaryrefslogtreecommitdiffstats
path: root/vnet/Makefile.am
diff options
context:
space:
mode:
authorKeith Burns (alagalah) <alagalah@gmail.com>2016-05-04 16:11:38 -0700
committerDave Barach <openvpp@barachs.net>2016-05-05 11:45:22 +0000
commitfdff1e6ed540f2a04792fb64e04b0c7862dc2b8c (patch)
treee846f70e89a3992ca98c82759bd9d36dc7ed3fdb /vnet/Makefile.am
parent8f15e922f7f32c1beca5baa9a1a7f187ff5bdc4f (diff)
VPP-39 - refactoring of NSH into own folder
- common header files and structs used in both GRE and VXLAN-GPE Change-Id: I06d0b773e936fb011408817237059f24a4beb412 Signed-off-by: Keith Burns (alagalah) <alagalah@gmail.com>
Diffstat (limited to 'vnet/Makefile.am')
-rw-r--r--vnet/Makefile.am13
1 files changed, 10 insertions, 3 deletions
diff --git a/vnet/Makefile.am b/vnet/Makefile.am
index a69734d1530..9393c1a8772 100644
--- a/vnet/Makefile.am
+++ b/vnet/Makefile.am
@@ -397,6 +397,15 @@ nobase_include_HEADERS += \
########################################
+# NSH Map: nsh
+########################################
+
+nobase_include_HEADERS += \
+ vnet/nsh/nsh_packet.h \
+ vnet/nsh/nsh_error.def
+
+
+########################################
# Tunnel protocol: nsh-gre
########################################
@@ -406,9 +415,7 @@ libvnet_la_SOURCES += \
vnet/nsh-gre/decap.c
nobase_include_HEADERS += \
- vnet/nsh-gre/nsh_gre.h \
- vnet/nsh-gre/nsh_gre_packet.h \
- vnet/nsh-gre/nsh_gre_error.def
+ vnet/nsh-gre/nsh_gre.h
########################################
# Tunnel protocol: nsh-vxlan-gpe