aboutsummaryrefslogtreecommitdiffstats
path: root/vnet/Makefile.am
diff options
context:
space:
mode:
authorDave Barach <dave@barachs.net>2016-02-08 15:57:35 -0500
committerDave Barach <dave@barachs.net>2016-02-08 15:57:55 -0500
commitced48e7cbb36022f4ae105130efc5be25e1a11b2 (patch)
treec0843c63040b367f9c887749abde07b855263d7e /vnet/Makefile.am
parent3e7deb11b5980ff619773f691975de2bec7a3450 (diff)
Cisco Discovery Protocol, initial working attempt
There are multiple enhancement opportunities... Change-Id: I976772dc3802f8284e8c6457c001d68184831e25 Signed-off-by: Dave Barach <dave@barachs.net>
Diffstat (limited to 'vnet/Makefile.am')
-rw-r--r--vnet/Makefile.am13
1 files changed, 12 insertions, 1 deletions
diff --git a/vnet/Makefile.am b/vnet/Makefile.am
index bb138e6b0d7..44ce1077c21 100644
--- a/vnet/Makefile.am
+++ b/vnet/Makefile.am
@@ -191,10 +191,21 @@ libvnet_la_SOURCES += \
nobase_include_HEADERS += \
vnet/vxlan/vxlan.h \
- vnet/vxlan/vxlan_packet.h \
+ vnet/vxlan/vxlan_packet.h \
vnet/vxlan/vxlan_error.def
########################################
+# Layer 2 / CDP
+########################################
+libvnet_la_SOURCES += \
+ vnet/cdp/cdp_input.c \
+ vnet/cdp/cdp_node.c \
+ vnet/cdp/cdp_periodic.c
+
+nobase_include_HEADERS += \
+ vnet/cdp/cdp_protocol.h
+
+########################################
# Layer 2/3 "classify"
########################################
libvnet_la_SOURCES += \