aboutsummaryrefslogtreecommitdiffstats
path: root/vnet/Makefile.am
diff options
context:
space:
mode:
authorShwetha Bhandari <shwethab@cisco.com>2016-05-04 08:12:57 +0200
committerEd Warnicke <hagbard@gmail.com>2016-05-09 13:31:53 +0000
commit05866a16c093124e4083d68c7f21f6f1d019959b (patch)
tree422c02d837922b5e4c8772d111df49ce7c1920b8 /vnet/Makefile.am
parented09a050b7981b631dda6ee9de7bcc5b1279868e (diff)
VPP-44: iOAM service and path verification using shamir's secret sharing
Change-Id: I445ad13f8f93cb75cacc94192c4ae85c8ca14e35 Signed-off-by: Shwetha Bhandari <shwethab@cisco.com>
Diffstat (limited to 'vnet/Makefile.am')
-rw-r--r--vnet/Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/vnet/Makefile.am b/vnet/Makefile.am
index 9393c1a8772..1239a8b8df4 100644
--- a/vnet/Makefile.am
+++ b/vnet/Makefile.am
@@ -733,6 +733,16 @@ libvnetplugin_la_SOURCES += \
nobase_include_HEADERS += \
vnet/plugin/plugin.h
+########################################
+# Service Chain verification util
+########################################
+libvnet_la_SOURCES += \
+ vnet/lib-scv/scv_util.c
+
+nobase_include_HEADERS += \
+ vnet/lib-scv/scv_util.h \
+ vnet/lib-scv/math64.h
+
lib_LTLIBRARIES = libvnet.la libvnetplugin.la
dpdk_libs =