aboutsummaryrefslogtreecommitdiffstats
path: root/vnet/Makefile.am
diff options
context:
space:
mode:
authorPavel Kotucek <pkotucek@cisco.com>2016-12-20 12:17:37 +0100
committerDamjan Marion <damarion@cisco.com>2016-12-21 22:23:37 +0100
commitf07dc9e236506f50a0230e6680cf1402dea6a976 (patch)
tree1231d26efe59052d050e42682caa1810f9dc0a92 /vnet/Makefile.am
parent8b2b794ae99a2316caebceb65a5ab16f75536d6b (diff)
API refactoring : vhost_user
Change-Id: I8813d5500973079d582e0bb5f8c2052f8f31c5c7 Signed-off-by: Pavel Kotucek <pkotucek@cisco.com>
Diffstat (limited to 'vnet/Makefile.am')
-rw-r--r--vnet/Makefile.am9
1 files changed, 7 insertions, 2 deletions
diff --git a/vnet/Makefile.am b/vnet/Makefile.am
index d0f4d9e7e90..e871b1c37ad 100644
--- a/vnet/Makefile.am
+++ b/vnet/Makefile.am
@@ -20,6 +20,8 @@ BUILT_SOURCES = \
vnet/devices/af_packet/af_packet.api.json \
vnet/devices/netmap/netmap.api.h \
vnet/devices/netmap/netmap.api.json \
+ vnet/devices/virtio/vhost_user.api.h \
+ vnet/devices/virtio/vhost_user.api.json \
vnet/interface.api.h \
vnet/interface.api.json \
vnet/ip/ip.api.h \
@@ -751,10 +753,12 @@ endif
########################################
libvnet_la_SOURCES += \
- vnet/devices/virtio/vhost-user.c
+ vnet/devices/virtio/vhost-user.c \
+ vnet/devices/virtio/vhost_user_api.c
nobase_include_HEADERS += \
- vnet/devices/virtio/vhost-user.h
+ vnet/devices/virtio/vhost-user.h \
+ vnet/devices/virtio/vhost_user.api.h
########################################
# ssvm ethernet
@@ -947,6 +951,7 @@ apidir = $(prefix)/vnet
api_DATA = \
vnet/devices/af_packet/af_packet.api.json \
vnet/devices/netmap/netmap.api.json \
+ vnet/devices/virtio/vhost_user.api.json \
vnet/interface.api.json \
vnet/ip/ip.api.json \
vnet/l2/l2.api.json \