summaryrefslogtreecommitdiffstats
path: root/vnet/Makefile.am
diff options
context:
space:
mode:
authorDamjan Marion <damarion@cisco.com>2016-06-08 01:37:11 +0200
committerDave Barach <openvpp@barachs.net>2016-06-13 20:39:58 +0000
commit0247b4600235bc18e558a7c4267b59be897d714d (patch)
tree3a52c20a43b4c6eee1aaf829b493619106d865c4 /vnet/Makefile.am
parentc424879b4c01f1a9d9dc3a210454a570178d31a2 (diff)
Add worker-handoff node
worker-handoff node is universal node which taakes packets from the input node and hands them over to worker threads. Currently it supports flow hashing based on ipv4, ipv6 and mpls headers. New cli: set interface handoff <intrerface-name> workers <list> e.g. set interface handoff TenGigabitEthernet2/0/0 workers 3-6,9-10 Change-Id: Iaf0df83e69bb0e84969865e0e1cdb000b0864cf5 Signed-off-by: Damjan Marion <damarion@cisco.com>
Diffstat (limited to 'vnet/Makefile.am')
-rw-r--r--vnet/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/vnet/Makefile.am b/vnet/Makefile.am
index 9feffc50eae..41e066f2616 100644
--- a/vnet/Makefile.am
+++ b/vnet/Makefile.am
@@ -26,6 +26,7 @@ TESTS =
########################################
libvnet_la_SOURCES += \
vnet/config.c \
+ vnet/handoff.c \
vnet/interface.c \
vnet/interface_cli.c \
vnet/interface_format.c \
@@ -39,6 +40,7 @@ nobase_include_HEADERS += \
vnet/buffer.h \
vnet/config.h \
vnet/global_funcs.h \
+ vnet/handoff.h \
vnet/interface.h \
vnet/interface_funcs.h \
vnet/l3_types.h \