summaryrefslogtreecommitdiffstats
path: root/vnet/Makefile.am
diff options
context:
space:
mode:
authorDamjan Marion <damarion@cisco.com>2016-11-09 11:59:42 +0100
committerDave Barach <openvpp@barachs.net>2016-11-09 14:03:25 +0000
commit51327ac5f9ffbe74eb32f26697c563b92eadc3ce (patch)
tree164fbf4e4448553900a232b13334e3a9ef01b142 /vnet/Makefile.am
parent66bcab2fff54531a126ddabe3b377df3fc536731 (diff)
devices: create dummy device-input node to keep nexts in sync
device-input feature arc requires that all input-nodes have nexts in sync. packet-generator tends to call vlib_node_add_next when new stream is created and that puts nexts out of sync. With this change all input node are siblings of device-input node so call to vlib_node_add_next(...) will install same next to the whole family. Change-Id: I33d79492e5f30f348af19e527f36fe0222c524d7 Signed-off-by: Damjan Marion <damarion@cisco.com>
Diffstat (limited to 'vnet/Makefile.am')
-rw-r--r--vnet/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/vnet/Makefile.am b/vnet/Makefile.am
index 185c08a9627..fef928abd35 100644
--- a/vnet/Makefile.am
+++ b/vnet/Makefile.am
@@ -31,6 +31,7 @@ endif
########################################
libvnet_la_SOURCES += \
vnet/config.c \
+ vnet/devices/devices.c \
vnet/handoff.c \
vnet/interface.c \
vnet/interface_cli.c \
@@ -721,7 +722,6 @@ nobase_include_HEADERS += \
########################################
libvnet_la_SOURCES += \
- vnet/devices/feature.c \
vnet/feature/feature.c \
vnet/feature/registration.c