summaryrefslogtreecommitdiffstats
path: root/vnet/Makefile.am
diff options
context:
space:
mode:
authorFlorin Coras <fcoras@cisco.com>2016-04-26 00:17:24 +0200
committerDave Barach <openvpp@barachs.net>2016-04-29 12:01:15 +0000
commit02655bd425cc596960b7efc74d1fbad3b3406419 (patch)
treecf840b76a83e27574f97d67ca4a1d22ea7290e53 /vnet/Makefile.am
parent848191d3e1b1b2febb1f67e5121487f871e67b56 (diff)
Add lisp-gpe ip6 data-plane support
The implementation mimics that of the ip4 data-plane. Therefore, a new lgpe-ip6-lookup lookup node is introduced for ip6 source lookups, a lisp-gpe-ip6-input node for decapsulating ip6 encapsulated packets and the tx function of the lisp-gpe interface is updated to support any mix of v4 and v6 in underlay and overlay. Change-Id: Ib3a6e339b8cd7618a940acf0dd8e61c042fd83dd Signed-off-by: Florin Coras <fcoras@cisco.com>
Diffstat (limited to 'vnet/Makefile.am')
-rw-r--r--vnet/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/vnet/Makefile.am b/vnet/Makefile.am
index 5fdffcaa13d..d8778eb6a10 100644
--- a/vnet/Makefile.am
+++ b/vnet/Makefile.am
@@ -478,6 +478,7 @@ endif
libvnet_la_SOURCES += \
vnet/lisp-gpe/lisp_gpe.c \
vnet/lisp-gpe/interface.c \
+ vnet/lisp-gpe/ip_forward.c \
vnet/lisp-gpe/decap.c
nobase_include_HEADERS += \