summaryrefslogtreecommitdiffstats
path: root/vnet/Makefile.am
diff options
context:
space:
mode:
authorFlorin Coras <fcoras@cisco.com>2016-04-21 00:45:40 +0200
committerDave Barach <openvpp@barachs.net>2016-04-25 13:05:49 +0000
commit577c3553dd6939e998c78c5a389750aac3a67f8b (patch)
tree3a95da61f5cfca2d1629a8011d2a6b57ae19bad2 /vnet/Makefile.am
parent405e41b50e336dccfdeeafae93bf4453774ecfec (diff)
Convert lisp-gpe encap to interface tx node
With this change, one lisp-gpe interface is created per vrf/overlay tenant and its tx node is used as encapsulator (or tunnel ingress). For all intents and purposes, the tx node inherits all functions previously performed by the lisp-gpe-encap node and it maintains said node's position in lisp-gpe's data-path graph. Chiefly, this opens the possibility to chain interface features, like IPSec, transparently with LISP. Furthermore, it brings basic data plane support for vrfs and LISP instance-ids (or virtual network instances as per RFC7364). Other changes include improvements to lisp-gpe enable and disable sequences and corresponding API/VAT fixes. Change-Id: I085500450660a976b587b1a720e282f6e728d580 Signed-off-by: Florin Coras <fcoras@cisco.com>
Diffstat (limited to 'vnet/Makefile.am')
-rw-r--r--vnet/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/vnet/Makefile.am b/vnet/Makefile.am
index 2ce40f3ec72..f7c1f30b520 100644
--- a/vnet/Makefile.am
+++ b/vnet/Makefile.am
@@ -477,7 +477,7 @@ endif
libvnet_la_SOURCES += \
vnet/lisp-gpe/lisp_gpe.c \
- vnet/lisp-gpe/encap.c \
+ vnet/lisp-gpe/interface.c \
vnet/lisp-gpe/decap.c
nobase_include_HEADERS += \