summaryrefslogtreecommitdiffstats
path: root/vnet/Makefile.am
diff options
context:
space:
mode:
authorKlement Sekera <ksekera@cisco.com>2016-09-13 12:27:08 +0200
committerDamjan Marion <dmarion.lists@gmail.com>2016-09-13 16:05:04 +0000
commitde4582b4c25f30412a8eab5f7741e577a1387fec (patch)
treee4321668fa75dea6b98f6b7b2149bffd58cfbd86 /vnet/Makefile.am
parent7e68220de8c9aba533bfb85b642b0b6b8caaee29 (diff)
VPP-344 Add LLDP feature
Change-Id: Iac96773e7f9028c0f09c3388893e69f67177439d Signed-off-by: Klement Sekera <ksekera@cisco.com>
Diffstat (limited to 'vnet/Makefile.am')
-rw-r--r--vnet/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/vnet/Makefile.am b/vnet/Makefile.am
index 1c28ebc40bb..1c47c658ac7 100644
--- a/vnet/Makefile.am
+++ b/vnet/Makefile.am
@@ -230,6 +230,18 @@ nobase_include_HEADERS += \
vnet/cdp/cdp_protocol.h
########################################
+# Layer 2 / LLDP
+########################################
+libvnet_la_SOURCES += \
+ vnet/lldp/lldp_input.c \
+ vnet/lldp/lldp_node.c \
+ vnet/lldp/lldp_output.c \
+ vnet/lldp/lldp_cli.c
+
+nobase_include_HEADERS += \
+ vnet/lldp/lldp_protocol.h
+
+########################################
# Layer 2/3 "classify"
########################################
libvnet_la_SOURCES += \