summaryrefslogtreecommitdiffstats
path: root/vnet/Makefile.am
diff options
context:
space:
mode:
authorPierre Pfister <ppfister@cisco.com>2016-03-21 16:17:52 +0000
committerGerrit Code Review <gerrit@fd.io>2016-03-24 17:49:44 +0000
commitd6f5b96e6f4e1d5022b18f0ff575dce1d19e931c (patch)
tree53d7895530a55259fa0be5f19db7016934c29dc5 /vnet/Makefile.am
parent2e89a894a46e6de80bdd3bcec184a53b32e5c091 (diff)
l2-rw: Packet rewrite feature for L2 bridges
This patch defines a new l2input feature: l2-rw It makes use of vnet_classify in order to match packets and applies mask/value changes depending on the matched classify entry. Change-Id: Ia98c128931e59195bf3ecb66721e155ff9049a2e Signed-off-by: Pierre Pfister <ppfister@cisco.com>
Diffstat (limited to 'vnet/Makefile.am')
-rw-r--r--vnet/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/vnet/Makefile.am b/vnet/Makefile.am
index c0115eb1368..460becbfff9 100644
--- a/vnet/Makefile.am
+++ b/vnet/Makefile.am
@@ -114,6 +114,7 @@ libvnet_la_SOURCES += \
vnet/l2/l2_output_acl.c \
vnet/l2/l2_output.c \
vnet/l2/l2_patch.c \
+ vnet/l2/l2_rw.c \
vnet/l2/l2_vtr.c \
vnet/l2/l2_xcrw.c
@@ -129,6 +130,7 @@ nobase_include_HEADERS += \
vnet/l2/l2_bvi.h \
vnet/l2/l2_flood.h \
vnet/l2/l2_fib.h \
+ vnet/l2/l2_rw.h \
vnet/l2/l2_xcrw.h \
vnet/l2/l2_classify.h