summaryrefslogtreecommitdiffstats
path: root/vnet/Makefile.am
diff options
context:
space:
mode:
authorAlexander Popovsky (apopovsk) <apopovsk@cisco.com>2016-10-05 22:31:23 -0700
committerJohn Lo <loj@cisco.com>2016-10-07 15:31:50 +0000
commit4a7e58bf481adb843707eec4a81213776a6d5212 (patch)
tree18e80de3e457e618752dbbe3740104e9f292dc14 /vnet/Makefile.am
parent02c826c6abf8dc5ca95b05b219532d9bb0f10312 (diff)
VPP-395 Add udp-punt node(s) and API
Uses existing UDP local API in order to register requested UDP port punt to the host. CLI: set punt udp [del] <port> API: punt protocol <l4-protocol> [ip <ver>] [port <l4-port>] [del] * Only UDP (l4-protocol = 17) is supported at this time Change-Id: I9232af1c891d1ed174d77f3e0dfe60c4b9d85e40 Signed-off-by: Alex Popovsky <apopovsk@cisco.com>
Diffstat (limited to 'vnet/Makefile.am')
-rw-r--r--vnet/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/vnet/Makefile.am b/vnet/Makefile.am
index 1b7b96911f9..88d556404b7 100644
--- a/vnet/Makefile.am
+++ b/vnet/Makefile.am
@@ -290,6 +290,7 @@ libvnet_la_SOURCES += \
vnet/ip/udp_format.c \
vnet/ip/udp_init.c \
vnet/ip/udp_local.c \
+ vnet/ip/punt.c \
vnet/ip/udp_pg.c \
vnet/ip/ip_input_acl.c \
vnet/ip/ip_frag.c
@@ -319,7 +320,9 @@ nobase_include_HEADERS += \
vnet/ip/tcp_packet.h \
vnet/ip/udp.h \
vnet/ip/udp_error.def \
- vnet/ip/udp_packet.h
+ vnet/ip/udp_packet.h \
+ vnet/ip/punt_error.def \
+ vnet/ip/punt.h
########################################
# Layer 3 protocol: IPSec