summaryrefslogtreecommitdiffstats
path: root/vnet/Makefile.am
diff options
context:
space:
mode:
authorEd Warnicke <eaw@cisco.com>2015-12-14 17:36:44 +0000
committerGerrit Code Review <gerrit@projectrotterdam.info>2015-12-14 17:36:44 +0000
commit64f98e91b669ecda59fcb587e095d0fb6b3dc48d (patch)
tree73771e86a59fd087c5b88ee4f9df37841664af0d /vnet/Makefile.am
parentee4e9ec5b3d94c580329ee8fa98304055be052fe (diff)
parent4e281a48e2afd258188c9ad996c46f166d4cfd9f (diff)
Merge "Move rpc handler where it belongs, related cleanup"
Diffstat (limited to 'vnet/Makefile.am')
-rw-r--r--vnet/Makefile.am9
1 files changed, 1 insertions, 8 deletions
diff --git a/vnet/Makefile.am b/vnet/Makefile.am
index ee01bff1ee9..1bde1e8082c 100644
--- a/vnet/Makefile.am
+++ b/vnet/Makefile.am
@@ -18,6 +18,7 @@ AM_CFLAGS = -Wall @DPDK@ @VIRL@
libvnet_la_SOURCES =
libvnetplugin_la_SOURCES =
nobase_include_HEADERS =
+noinst_PROGRAMS =
########################################
# Generic stuff
@@ -608,20 +609,12 @@ nobase_include_HEADERS += \
lib_LTLIBRARIES = libvnet.la libvnetplugin.la
-noinst_PROGRAMS = vnet_unix
-
-vnet_unix_SOURCES = \
- example/main_stub.c
-
-vnet_unix_LDFLAGS = -static
dpdk_libs =
if WITH_DPDK
dpdk_libs += -l:libdpdk.a
endif
-vnet_unix_LDADD = libvnet.la -l:libvlib_unix.a -l:libvlib.a -l:libvppinfra.a -lpthread -lvlibapi -lvlibmemory -lsvm -lm -ldl $(dpdk_libs) -lrt
-
pcap2pg_SOURCES = \
vnet/unix/pcap2pg.c \
vnet/unix/pcap.h