summaryrefslogtreecommitdiffstats
path: root/vnet/configure.ac
diff options
context:
space:
mode:
authorFilip Tehlar <ftehlar@cisco.com>2016-04-07 10:04:34 +0200
committerGerrit Code Review <gerrit@fd.io>2016-04-12 11:47:39 +0000
commit254b036dff8ac1ffc663788766de999a2837dc7e (patch)
tree8bb19e5a1d3503cc4c13803c99cd43dc52a8cb22 /vnet/configure.ac
parent42f2006975c5a0ea58c835df4461213072f8813f (diff)
Add unit test infrastructure for LISP protocol
Change-Id: I802700ad832de1dc6f4a1981e8985aa6e926c8ad Signed-off-by: Filip Tehlar <ftehlar@cisco.com>
Diffstat (limited to 'vnet/configure.ac')
-rw-r--r--vnet/configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/vnet/configure.ac b/vnet/configure.ac
index b46a6787836..b4b6723a693 100644
--- a/vnet/configure.ac
+++ b/vnet/configure.ac
@@ -32,6 +32,11 @@ AC_ARG_WITH(ipv6sr,
[with_ipv6sr=0],
[with_ipv6sr=1])
+AC_ARG_ENABLE(tests,
+ AC_HELP_STRING([--enable-tests], [Build unit tests]),
+ [enable_tests=1],
+ [enable_tests=0])
+
AM_CONDITIONAL(WITH_DPDK, test "$with_dpdk" = "1")
AC_SUBST(DPDK,[-DDPDK=${with_dpdk}])
@@ -47,4 +52,6 @@ AC_SUBST(VCGN,[-DVCGN=${with_vcgn}])
AM_CONDITIONAL(WITH_IPV6SR, test "$with_ipv6sr" = "1")
AC_SUBST(IPV6SR,[-DIPV6SR=${with_ipv6sr}])
+AM_CONDITIONAL(ENABLE_TESTS, test "$enable_tests" = "1")
+
AC_OUTPUT([Makefile])