aboutsummaryrefslogtreecommitdiffstats
path: root/vpp-api/python/setup.py
diff options
context:
space:
mode:
authorOle Troan <ot@cisco.com>2016-09-12 22:00:32 +0200
committerDamjan Marion <dmarion.lists@gmail.com>2016-09-23 13:18:46 +0000
commit57c3d66c55580f2ced6993ada22274941237fcd5 (patch)
tree55a856b3ddcc4f9e5284c7bc42b0126616825366 /vpp-api/python/setup.py
parent5fef9e523df67a96f3b9aedcec373e65f590b001 (diff)
Python API: Preparation for RPM/DEB packaging.
Recheck. Repackage the Python API binding to include all necessary modules in a single Python package. Change-Id: I5e35141d413bfb1aad650217e1ca07d85646c349 Signed-off-by: Ole Troan <ot@cisco.com>
Diffstat (limited to 'vpp-api/python/setup.py')
-rw-r--r--vpp-api/python/setup.py30
1 files changed, 24 insertions, 6 deletions
diff --git a/vpp-api/python/setup.py b/vpp-api/python/setup.py
index e369a0cb479..a2eeff3f436 100644
--- a/vpp-api/python/setup.py
+++ b/vpp-api/python/setup.py
@@ -1,16 +1,34 @@
+#
+# Copyright (c) 2016 Cisco and/or its affiliates.
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
try:
- from setuptools import setup
+ from setuptools import setup, command, Extension
except ImportError:
from distutils.core import setup
setup (name = 'vpp_papi',
- version = '1.1',
+ version = '1.2',
description = 'VPP Python binding',
author = 'Ole Troan',
author_email = 'ot@cisco.com',
- #url = 'https://docs.python.org/extending/building',
test_suite = 'tests',
packages=['vpp_papi'],
- long_description = '''
-VPP Python language binding.
-''',)
+ ext_modules = [
+ Extension(
+ 'vpp_api',
+ sources = ['vpp_papi/pneum_wrap.c'],
+ libraries = ['pneum'],
+ )],
+ long_description = '''VPP Python language binding.''',
+)