aboutsummaryrefslogtreecommitdiffstats
path: root/vpp-api/python/setup.py
diff options
context:
space:
mode:
authorOle Troan <ot@cisco.com>2016-12-02 12:53:55 +0100
committerDamjan Marion <dmarion.lists@gmail.com>2016-12-02 13:35:46 +0000
commita03f4efa92eb805d627e2f2f0cf55f70ea17c2fb (patch)
treeced6731033f6e58cb73b25cbdbd353263999ab0d /vpp-api/python/setup.py
parent58290ea2f6364fdc6f0dd9c201d6d0b84025f3d3 (diff)
Python API: Support for per message CRC and API split.
These changes are incompatible with Python VPP API 1.2 There is now a new VPP Class and it can be used like: from vpp_papi import VPP jsonfiles = [] for root, dirnames, filenames in os.walk('../../../build-root/'): if root.find('install-') == -1: continue for filename in fnmatch.filter(filenames, '*.api.json'): jsonfiles.append(os.path.join(root, filename)) vpp = VPP(jsonfiles) rv = vpp.show_version() print('RV', rv.program.decode().rstrip('\0x00')) vpp.disconnect() Change-Id: Ic92d226de2cf3626e750404012247e7fc24fb7fc Signed-off-by: Ole Troan <ot@cisco.com>
Diffstat (limited to 'vpp-api/python/setup.py')
-rw-r--r--vpp-api/python/setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/vpp-api/python/setup.py b/vpp-api/python/setup.py
index cd7afc8a2ff..99a0147a56f 100644
--- a/vpp-api/python/setup.py
+++ b/vpp-api/python/setup.py
@@ -18,7 +18,7 @@ except ImportError:
from distutils.core import setup, Extension
setup (name = 'vpp_papi',
- version = '1.2',
+ version = '1.3',
description = 'VPP Python binding',
author = 'Ole Troan',
author_email = 'ot@cisco.com',