summaryrefslogtreecommitdiffstats
path: root/vpp-api/python/setup.py
diff options
context:
space:
mode:
authorOle Troan <ot@cisco.com>2016-08-01 04:59:13 +0200
committerDamjan Marion <dmarion.lists@gmail.com>2016-08-25 00:29:40 +0000
commit5f9dcff39d5e25c6bef30d569e405635633f3c69 (patch)
treeec14d5fdb45a9d82cf5703d63e0bcafcc40d4da0 /vpp-api/python/setup.py
parent151fb725636f192da8a04d0f74dc3455b58dd61c (diff)
VPP Python language binding - plugin support
- Moved Python generator tool to tools directory - Added build-vpp-api Makefile target - Generator now only creates a Python representation of the .api the rest of the framework is in the vpp_papi script - Each plugin has its own namespace. - Plugin Python files are installed in vpp_papi_plugins for easy use inside the build tree. Change-Id: I272c83bb7e5d5e416bdbd8a790a3cc35c5a04e38 Signed-off-by: Ole Troan <ot@cisco.com>
Diffstat (limited to 'vpp-api/python/setup.py')
-rw-r--r--vpp-api/python/setup.py19
1 files changed, 7 insertions, 12 deletions
diff --git a/vpp-api/python/setup.py b/vpp-api/python/setup.py
index d890ba709dc..e369a0cb479 100644
--- a/vpp-api/python/setup.py
+++ b/vpp-api/python/setup.py
@@ -1,21 +1,16 @@
-from distutils.core import setup, Extension
-
-module1 = Extension('vpp_api',
- define_macros = [('MAJOR_VERSION', '1'),
- ('MINOR_VERSION', '0')],
- include_dirs = ['pneum'],
- libraries = ['pneum'],
- library_dirs = ['../../build-root/install-vpp_debug-native/vpp-api/lib64'],
- sources = ['vpp_papi/pneum_wrap.c'])
+try:
+ from setuptools import setup
+except ImportError:
+ from distutils.core import setup
setup (name = 'vpp_papi',
- version = '1.0',
+ version = '1.1',
description = 'VPP Python binding',
author = 'Ole Troan',
author_email = 'ot@cisco.com',
#url = 'https://docs.python.org/extending/building',
+ test_suite = 'tests',
packages=['vpp_papi'],
long_description = '''
VPP Python language binding.
-''',
- ext_modules = [module1])
+''',)