summaryrefslogtreecommitdiffstats
path: root/vpp-api/python/setup.py
diff options
context:
space:
mode:
authorOle Troan <ot@cisco.com>2016-04-09 03:16:30 +0200
committerDave Wallace <dwallacelf@gmail.com>2016-04-20 16:50:29 +0000
commit6855f6cdfee8c479f1e0ae440ce87a91ff41a708 (patch)
treee438e21c8107a675dc3a3141c6af6ba0ab458992 /vpp-api/python/setup.py
parent633951c3d8dc1640813b4778f3e35463d08f3795 (diff)
Python-API: Inital commit of Python bindings for the VPP API.
See: https://wiki.fd.io/view/VPP/Python_API Change-Id: If135fc32208c7031787e1935b399d930e0e1ea1f Signed-off-by: Ole Troan <ot@cisco.com>
Diffstat (limited to 'vpp-api/python/setup.py')
-rw-r--r--vpp-api/python/setup.py21
1 files changed, 21 insertions, 0 deletions
diff --git a/vpp-api/python/setup.py b/vpp-api/python/setup.py
new file mode 100644
index 00000000000..d890ba709dc
--- /dev/null
+++ b/vpp-api/python/setup.py
@@ -0,0 +1,21 @@
+from distutils.core import setup, Extension
+
+module1 = Extension('vpp_api',
+ define_macros = [('MAJOR_VERSION', '1'),
+ ('MINOR_VERSION', '0')],
+ include_dirs = ['pneum'],
+ libraries = ['pneum'],
+ library_dirs = ['../../build-root/install-vpp_debug-native/vpp-api/lib64'],
+ sources = ['vpp_papi/pneum_wrap.c'])
+
+setup (name = 'vpp_papi',
+ version = '1.0',
+ description = 'VPP Python binding',
+ author = 'Ole Troan',
+ author_email = 'ot@cisco.com',
+ #url = 'https://docs.python.org/extending/building',
+ packages=['vpp_papi'],
+ long_description = '''
+VPP Python language binding.
+''',
+ ext_modules = [module1])