summaryrefslogtreecommitdiffstats
path: root/vpp-api/python/setup.py
diff options
context:
space:
mode:
authorDamjan Marion <damarion@cisco.com>2016-12-19 23:05:39 +0100
committerDamjan Marion <damarion@cisco.com>2016-12-28 12:25:14 +0100
commit7cd468a3d7dee7d6c92f69a0bb7061ae208ec727 (patch)
tree5de62f8dbd3a752f5a676ca600e43d2652d1ff1a /vpp-api/python/setup.py
parent696f1adec0df3b8f161862566dd9c86174302658 (diff)
Reorganize source tree to use single autotools instance
Change-Id: I7b51f88292e057c6443b12224486f2d0c9f8ae23 Signed-off-by: Damjan Marion <damarion@cisco.com>
Diffstat (limited to 'vpp-api/python/setup.py')
-rw-r--r--vpp-api/python/setup.py34
1 files changed, 0 insertions, 34 deletions
diff --git a/vpp-api/python/setup.py b/vpp-api/python/setup.py
deleted file mode 100644
index 99a0147a56f..00000000000
--- a/vpp-api/python/setup.py
+++ /dev/null
@@ -1,34 +0,0 @@
-#
-# Copyright (c) 2016 Cisco and/or its affiliates.
-# Licensed under the Apache License, Version 2.0 (the "License");
-# you may not use this file except in compliance with the License.
-# You may obtain a copy of the License at:
-#
-# http://www.apache.org/licenses/LICENSE-2.0
-#
-# Unless required by applicable law or agreed to in writing, software
-# distributed under the License is distributed on an "AS IS" BASIS,
-# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-# See the License for the specific language governing permissions and
-# limitations under the License.
-
-try:
- from setuptools import setup, Extension
-except ImportError:
- from distutils.core import setup, Extension
-
-setup (name = 'vpp_papi',
- version = '1.3',
- description = 'VPP Python binding',
- author = 'Ole Troan',
- author_email = 'ot@cisco.com',
- test_suite = 'tests',
- packages=['vpp_papi'],
- ext_modules = [
- Extension(
- 'vpp_api',
- sources = ['vpp_papi/pneum_wrap.c'],
- libraries = ['pneum'],
- )],
- long_description = '''VPP Python language binding.''',
-)