summaryrefslogtreecommitdiffstats
path: root/vppinfra/Makefile.am
diff options
context:
space:
mode:
authorDave Wallace <dwallacelf@gmail.com>2015-12-15 13:20:55 +0000
committerGerrit Code Review <gerrit@projectrotterdam.info>2015-12-15 13:20:55 +0000
commitec65a1afd3f118849a7629d99ab2a1dcd2dda341 (patch)
tree249f8c92d27b02a63fe844d107a42920d727836e /vppinfra/Makefile.am
parent5e7ac9dc825d06b30bfb970860ccc7a3f2696c6e (diff)
parent29b6af9f97b0002a4ba495eade7727c1ecb4f3c2 (diff)
Merge "Remove vppversion subtree, move elftool to vppinfra"
Diffstat (limited to 'vppinfra/Makefile.am')
-rw-r--r--vppinfra/Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/vppinfra/Makefile.am b/vppinfra/Makefile.am
index 388845a4f51..e3a7d46def4 100644
--- a/vppinfra/Makefile.am
+++ b/vppinfra/Makefile.am
@@ -266,3 +266,9 @@ libvppinfra_la_SOURCES = \
vppinfra/timer.c \
vppinfra/unix-formats.c \
vppinfra/unix-misc.c
+
+bin_PROGRAMS = elftool
+
+elftool_SOURCES = tools/elftool.c
+elftool_CPPFLAGS = -Wall
+elftool_LDADD = libvppinfra.la -lpthread -lrt -lm