summaryrefslogtreecommitdiffstats
path: root/vppinfra/configure.ac
diff options
context:
space:
mode:
authorDamjan Marion <damarion@cisco.com>2016-04-11 13:34:36 +0200
committerGerrit Code Review <gerrit@fd.io>2016-04-11 13:03:30 +0000
commitc47e9796746f96f1f8f08fb95c98f5bf632705f4 (patch)
treec941d1cebd51bbee6618ff1eca6b042cd7ba6d00 /vppinfra/configure.ac
parentdba76f29e6ab51b0f3fd01ca2928652186392132 (diff)
Add configure option to enable building unit tests
Same template should be used for other libs... Change-Id: Icc771cb6b243d215f30fb51c0dbc028e497a74c6 Signed-off-by: Damjan Marion <damarion@cisco.com>
Diffstat (limited to 'vppinfra/configure.ac')
-rw-r--r--vppinfra/configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/vppinfra/configure.ac b/vppinfra/configure.ac
index d0b3a0c0dd2..712186af39d 100644
--- a/vppinfra/configure.ac
+++ b/vppinfra/configure.ac
@@ -31,6 +31,13 @@ AC_ARG_WITH(ldflags,
######################################################################
+AC_ARG_ENABLE(tests,
+ AC_HELP_STRING([--enable-tests],[Enable unit tests]),
+ [enable_tests=1],
+ [enable_tests=0])
+
+AM_CONDITIONAL(ENABLE_TESTS, test "$enable_tests" = "1")
+
AC_ARG_WITH(unix,
AC_HELP_STRING([--with-unix],[Compile unix version of clib]),
[],