summaryrefslogtreecommitdiffstats
path: root/build-data/packages/vpp.mk
diff options
context:
space:
mode:
Diffstat (limited to 'build-data/packages/vpp.mk')
-rw-r--r--build-data/packages/vpp.mk9
1 files changed, 6 insertions, 3 deletions
diff --git a/build-data/packages/vpp.mk b/build-data/packages/vpp.mk
index 02aca4e6426..54aa548482c 100644
--- a/build-data/packages/vpp.mk
+++ b/build-data/packages/vpp.mk
@@ -1,6 +1,5 @@
vpp_configure_depend = \
vppinfra-install \
- dpdk-install \
svm-install \
vlib-api-install \
vlib-install \
@@ -15,7 +14,6 @@ vpp_configure_args += $(vpp_configure_args_$(PLATFORM))
vpp_CPPFLAGS = $(call installed_includes_fn, \
vppinfra \
- dpdk \
openssl \
svm \
vlib \
@@ -24,9 +22,14 @@ vpp_CPPFLAGS = $(call installed_includes_fn, \
vpp_LDFLAGS = $(call installed_libs_fn, \
vppinfra \
- dpdk \
openssl \
svm \
vlib \
vlib-api \
vnet)
+
+ifeq ($($(PLATFORM)_uses_dpdk),yes)
+vpp_configure_depend += dpdk-install
+vpp_CPPFLAGS += $(call installed_includes_fn, dpdk)
+vpp_LDFLAGS += $(call installed_libs_fn, dpdk)
+endif