summaryrefslogtreecommitdiffstats
path: root/build-root/deb/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'build-root/deb/debian/rules')
-rwxr-xr-xbuild-root/deb/debian/rules38
1 files changed, 0 insertions, 38 deletions
diff --git a/build-root/deb/debian/rules b/build-root/deb/debian/rules
deleted file mode 100755
index 39be1b57e04..00000000000
--- a/build-root/deb/debian/rules
+++ /dev/null
@@ -1,38 +0,0 @@
-#!/usr/bin/make -f
-# See debhelper(7) (uncomment to enable)
-# output every command that modifies files on the build system.
-DH_VERBOSE = 1
-
-# see EXAMPLES in dpkg-buildflags(1) and read /usr/share/dpkg/*
-DPKG_EXPORT_BUILDFLAGS = 1
-include /usr/share/dpkg/default.mk
-
-# see FEATURE AREAS in dpkg-buildflags(1)
-#export DEB_BUILD_MAINT_OPTIONS = hardening=+all
-
-# see ENVIRONMENT in dpkg-buildflags(1)
-# package maintainers to append CFLAGS
-#export DEB_CFLAGS_MAINT_APPEND = -Wall -pedantic
-# package maintainers to append LDFLAGS
-#export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
-
-export PYBUILD_NAME = vpp-api-python
-export PYBUILD_DIR = ../../src/vpp-api/python
-export PYBUILD_DESTDIR_python2=debian/vpp-api-python/
-export PYBUILD_DISABLE_python2=test
-export PYBUILD_SYSTEM=distutils
-
-# main packaging script based on dh7 syntax
-%:
- dh $@ --with systemd,python2 --buildsystem=pybuild
-
-override_dh_install:
- dh_install --exclude .git
- ../scripts/remove-rpath .
-
-override_dh_shlibdeps:
- @dh_shlibdeps 2>&1 \
- | { grep -v -e "probably a plugin" -e "similar warnings have been skipped" || true; }
-
-override_dh_strip:
- dh_strip --dbg-package=vpp-dbg