summaryrefslogtreecommitdiffstats
path: root/build-root/deb/debian
diff options
context:
space:
mode:
Diffstat (limited to 'build-root/deb/debian')
-rw-r--r--build-root/deb/debian/control2
-rwxr-xr-xbuild-root/deb/debian/rules2
-rw-r--r--build-root/deb/debian/vpp.service14
3 files changed, 16 insertions, 2 deletions
diff --git a/build-root/deb/debian/control b/build-root/deb/debian/control
index cf22fd021bb..97464e42680 100644
--- a/build-root/deb/debian/control
+++ b/build-root/deb/debian/control
@@ -2,7 +2,7 @@ Source: vpp
Section: net
Priority: extra
Maintainer: Cisco OpenVPP Packaging Team <bogus.address@cisco.com>
-Build-Depends: debhelper (>= 9), dkms
+Build-Depends: debhelper (>= 9), dkms, dh-systemd
Standards-Version: 3.9.4
Package: vpp
diff --git a/build-root/deb/debian/rules b/build-root/deb/debian/rules
index bcee0121ff6..b5afbdb62fb 100755
--- a/build-root/deb/debian/rules
+++ b/build-root/deb/debian/rules
@@ -18,7 +18,7 @@ include /usr/share/dpkg/default.mk
# main packaging script based on dh7 syntax
%:
- dh $@ --with dkms
+ dh $@ --with dkms --with systemd
override_dh_install:
dh_install --exclude .git
diff --git a/build-root/deb/debian/vpp.service b/build-root/deb/debian/vpp.service
new file mode 100644
index 00000000000..a2849296cdc
--- /dev/null
+++ b/build-root/deb/debian/vpp.service
@@ -0,0 +1,14 @@
+[Unit]
+Description=vector packet processing engine
+After=network.target
+
+[Service]
+Type=simple
+ExecStartPre=-/bin/rm -f /dev/shm/*
+ExecStartPre=-/sbin/modprobe igb_uio
+ExecStart=/usr/bin/vpp -c /etc/vpp/startup.conf
+ExecStopPost=/bin/rm -f /dev/shm/*
+Restart=always
+
+[Install]
+WantedBy=multi-user.target