summaryrefslogtreecommitdiffstats
path: root/extras/libmemif/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'extras/libmemif/Makefile.am')
-rw-r--r--extras/libmemif/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/extras/libmemif/Makefile.am b/extras/libmemif/Makefile.am
index 48e4bb89b86..1ff7e7e5a5a 100644
--- a/extras/libmemif/Makefile.am
+++ b/extras/libmemif/Makefile.am
@@ -17,6 +17,9 @@ ACLOCAL_AMFLAGS = -I m4
AM_CPPFLAGS = -g -DMEMIF_DBG -DICMP_DBG
+SRCS_C := $(shell find . -name "*.c" )
+SRCS_H := $(shell find . -name "*.h" )
+
.PHONY: release
release:
$(MAKE) AM_CPPFLAGS="-O3"
@@ -27,6 +30,12 @@ doc:
doxygen doxygen.conf
@echo Doxygen documentation built in docs directory.
+.PHONY: fixstyle
+fixstyle:
+ @echo Fixing code style...
+ indent $(SRCS_C) $(SRCS_H)
+ @echo Code style fixed!
+
#
# unit_test
#