summaryrefslogtreecommitdiffstats
path: root/extras/rpm/vpp.spec
diff options
context:
space:
mode:
Diffstat (limited to 'extras/rpm/vpp.spec')
-rw-r--r--extras/rpm/vpp.spec26
1 files changed, 0 insertions, 26 deletions
diff --git a/extras/rpm/vpp.spec b/extras/rpm/vpp.spec
index f04eecc5c24..8ab89ad8748 100644
--- a/extras/rpm/vpp.spec
+++ b/extras/rpm/vpp.spec
@@ -10,17 +10,6 @@
%endif
%define _vpp_install_dir install-%{_vpp_tag}-native
-# Failsafe backport of Python2-macros for RHEL <= 6
-%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")}
-%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print(get_python_lib(1))")}
-%{!?python_version: %global python_version %(%{__python} -c "import sys; sys.stdout.write(sys.version[:3])")}
-%{!?__python2: %global __python2 %{__python}}
-%{!?python2_sitelib: %global python2_sitelib %{python_sitelib}}
-%{!?python2_sitearch: %global python2_sitearch %{python_sitearch}}
-%{!?python2_version: %global python2_version %{python_version}}
-
-%{!?python2_minor_version: %define python2_minor_version %(%{__python} -c "import sys ; print sys.version[2:3]")}
-
%{?systemd_requires}
@@ -136,15 +125,6 @@ Requires: vpp = %{_version}-%{_release}, vpp-lib = %{_version}-%{_release}
%description api-lua
This package contains the lua bindings for the vpp api
-%package api-python
-Summary: VPP api python bindings
-Group: Development/Libraries
-Requires: vpp = %{_version}-%{_release}, vpp-lib = %{_version}-%{_release}, libffi-devel
-Requires: python-setuptools
-
-%description api-python
-This package contains the python bindings for the vpp api
-
%package api-python3
Summary: VPP api python3 bindings
Group: Development/Libraries
@@ -188,7 +168,6 @@ groupadd -f -r vpp
make bootstrap AESNI=n
make -C build-root PLATFORM=vpp AESNI=n TAG=%{_vpp_tag} install-packages
%endif
-cd %{_mu_build_dir}/../src/vpp-api/python && %py2_build
cd %{_mu_build_dir}/../src/vpp-api/python && %py3_build
cd %{_mu_build_dir}/../extras/selinux && make -f %{_datadir}/selinux/devel/Makefile
@@ -245,7 +224,6 @@ do
done
# Python bindings
-cd %{_mu_build_dir}/../src/vpp-api/python && %py2_install
cd %{_mu_build_dir}/../src/vpp-api/python && %py3_install
# SELinux Policy
@@ -399,10 +377,6 @@ fi
%defattr(644,root,root,644)
/usr/share/doc/vpp/examples/lua
-%files api-python
-%defattr(644,root,root,755)
-%{python2_sitelib}/vpp_*
-
%files api-python3
%defattr(644,root,root,755)
%{python3_sitelib}/vpp_*