aboutsummaryrefslogtreecommitdiffstats
path: root/extras/vom/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'extras/vom/configure.ac')
-rw-r--r--extras/vom/configure.ac20
1 files changed, 20 insertions, 0 deletions
diff --git a/extras/vom/configure.ac b/extras/vom/configure.ac
new file mode 100644
index 00000000000..0e15095e117
--- /dev/null
+++ b/extras/vom/configure.ac
@@ -0,0 +1,20 @@
+AC_INIT(vom, 18.07)
+LT_INIT
+AM_INIT_AUTOMAKE
+AM_SILENT_RULES([yes])
+AC_PREFIX_DEFAULT([/usr])
+
+PKG_CHECK_MODULES([CHECK], [check], [HAVE_CHECK=1], [HAVE_CHECK=0])
+AM_CONDITIONAL([USE_CHECK],[test "$HAVE_CHECK" -eq 1])
+
+AC_PROG_CC
+AC_PROG_CXX
+
+AM_CONDITIONAL(ENABLE_ACL_PLUGIN, test "yes" = "yes")
+AM_CONDITIONAL(ENABLE_NAT_PLUGIN, test "yes" = "yes")
+AM_CONDITIONAL(ENABLE_L2E_PLUGIN, test "yes" = "yes")
+AM_CONDITIONAL(ENABLE_GBP_PLUGIN, test "yes" = "yes")
+
+AC_OUTPUT([Makefile vom/Makefile])
+
+AC_CONFIG_MACRO_DIR([m4])