summaryrefslogtreecommitdiffstats
path: root/extras/vpp_config/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'extras/vpp_config/setup.py')
-rw-r--r--extras/vpp_config/setup.py22
1 files changed, 22 insertions, 0 deletions
diff --git a/extras/vpp_config/setup.py b/extras/vpp_config/setup.py
new file mode 100644
index 00000000000..3444e685f58
--- /dev/null
+++ b/extras/vpp_config/setup.py
@@ -0,0 +1,22 @@
+from setuptools import setup
+
+setup(name="vpp_config",
+ version="17.10.1",
+ author="John DeNisco",
+ author_email="jdenisco@cisco.com",
+ description="VPP Configuration Utility",
+ license = 'Apache-2.0',
+ keywords="vppconfig",
+ url = 'https://wiki.fd.io/view/VPP',
+ py_modules=['vpp_config'],
+ install_requires=['pyyaml'],
+ packages=['vpplib'],
+ scripts=['scripts/vpp-config'],
+ data_files=[('vpp/vpp-config/scripts', ['scripts/dpdk-devbind.py']),
+ ('vpp/vpp-config/configs', ['data/auto-config.yaml']),
+ ('vpp/vpp-config/dryrun/sysctl.d', ['data/80-vpp.conf.template']),
+ ('vpp/vpp-config/dryrun/default', ['data/grub.template']),
+ ('vpp/vpp-config/dryrun/vpp', ['data/startup.conf.template']),
+ ],
+ long_description="The VPP configuration utility can be used to easily configure VPP.",
+ )