aboutsummaryrefslogtreecommitdiffstats
path: root/g2/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'g2/configure.ac')
-rw-r--r--g2/configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/g2/configure.ac b/g2/configure.ac
new file mode 100644
index 00000000000..cd6522fc2ae
--- /dev/null
+++ b/g2/configure.ac
@@ -0,0 +1,13 @@
+AC_INIT(g2, 3.0)
+AM_INIT_AUTOMAKE
+
+AC_CHECK_LIB([vppinfra], [clib_mem_get_page_size],,
+ AC_MSG_ERROR([Please install the vpp-lib package]))
+AC_CHECK_HEADER([vppinfra/clib.h],,
+ AC_MSG_ERROR([Please install the vpp-dev package]))
+
+AM_PROG_AS
+AM_PROG_CC_C_O
+PKG_CHECK_MODULES(g2, gtk+-2.0)
+
+AC_OUTPUT([Makefile])