summaryrefslogtreecommitdiffstats
path: root/perftool/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'perftool/configure.ac')
-rw-r--r--perftool/configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/perftool/configure.ac b/perftool/configure.ac
new file mode 100644
index 00000000000..37a4174f1df
--- /dev/null
+++ b/perftool/configure.ac
@@ -0,0 +1,12 @@
+AC_INIT(perftool, 2.0)
+AM_INIT_AUTOMAKE
+
+AC_CHECK_LIB([vppinfra], [clib_mem_get_page_size],,
+ AC_MSG_ERROR([Please install the vpp-lib package]))
+AC_CHECK_HEADER([vppinfra/clib.h],,
+ AC_MSG_ERROR([Please install the vpp-dev package]))
+
+AM_PROG_LIBTOOL
+AM_PROG_CC_C_O
+
+AC_OUTPUT([Makefile])