summaryrefslogtreecommitdiffstats
path: root/plugins/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/Makefile.am')
-rw-r--r--plugins/Makefile.am20
1 files changed, 15 insertions, 5 deletions
diff --git a/plugins/Makefile.am b/plugins/Makefile.am
index 83dc70bfeda..350a00e3c3f 100644
--- a/plugins/Makefile.am
+++ b/plugins/Makefile.am
@@ -13,23 +13,33 @@
AUTOMAKE_OPTIONS = foreign subdir-objects
+# To add a new plugin subdirectory:
+#
+# add a stanza here:
+# if ENABLE_new_PLUGIN
+# SUBDIRS += new-plugin
+# endif
+#
+# Also: add PLUGIN(new) to configure.ac
+
SUBDIRS =
-if ENABLE_SAMPLE_PLUGIN
+
+if ENABLE_sample_PLUGIN
SUBDIRS += sample-plugin
endif
-if ENABLE_SIXRD_PLUGIN
+if ENABLE_sixrd_PLUGIN
SUBDIRS += sixrd-plugin
endif
-if ENABLE_IOAM_PLUGIN
+if ENABLE_ioam_PLUGIN
SUBDIRS += ioam-plugin
endif
-if ENABLE_VCGN_PLUGIN
+if ENABLE_vcgn_PLUGIN
SUBDIRS += vcgn-plugin
endif
-if ENABLE_SNAT_PLUGIN
+if ENABLE_snat_PLUGIN
SUBDIRS += snat-plugin
endif