summaryrefslogtreecommitdiffstats
path: root/plugins/lb-plugin/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/lb-plugin/Makefile.am')
-rw-r--r--plugins/lb-plugin/Makefile.am15
1 files changed, 14 insertions, 1 deletions
diff --git a/plugins/lb-plugin/Makefile.am b/plugins/lb-plugin/Makefile.am
index 8d92ff1dfc4..8e36027949e 100644
--- a/plugins/lb-plugin/Makefile.am
+++ b/plugins/lb-plugin/Makefile.am
@@ -24,13 +24,26 @@ vppplugins_LTLIBRARIES = lb_plugin.la
lb_plugin_la_SOURCES = lb/lb.c lb/node.c lb/cli.c lb/util.c lb/refcount.c lb/api.c
-SUFFIXES = .api.h .api
+BUILT_SOURCES = \
+ lb/lb.api.h \
+ lb/lb.api.json
+
+SUFFIXES = .api.h .api .api.json
%.api.h: %.api
mkdir -p `dirname $@` ; \
$(CC) $(CPPFLAGS) -E -P -C -x c $^ \
| vppapigen --input - --output $@ --show-name $@
+%.api.json: %.api
+ @echo " JSON APIGEN " $@ ; \
+ mkdir -p `dirname $@` ; \
+ $(CC) $(CPPFLAGS) -E -P -C -x c $^ \
+ | vppapigen --input - --json $@
+
+apidir = $(prefix)/lb/
+api_DATA = lb/lb.api.json
+
noinst_HEADERS = lb/lb.h lb/util.h lb/refcount.h lb/lbhash.h lb/lb.api.h
lb_test_plugin_la_SOURCES = \