aboutsummaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index d5c7fd1c718..1fbb624b972 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -164,7 +164,7 @@ elseif (${CMAKE_BUILD_TYPE_LC} MATCHES "coverity")
add_compile_options(-O0)
add_compile_definitions(__COVERITY__)
elseif (${CMAKE_BUILD_TYPE_LC} MATCHES "gcov")
- add_compile_options(-O0 -fprofile-arcs -ftest-coverage)
+ add_compile_options(-O0 -fprofile-arcs -ftest-coverage -fprofile-update=prefer-atomic)
add_compile_definitions(CLIB_DEBUG CLIB_GCOV)
link_libraries(gcov)
endif()