aboutsummaryrefslogtreecommitdiffstats
path: root/src/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'src/configure.ac')
-rw-r--r--src/configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/src/configure.ac b/src/configure.ac
index 74d5113b93e..26c2eb5510d 100644
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -231,6 +231,7 @@ PLUGIN_ENABLED(srv6am)
PLUGIN_ENABLED(srv6as)
PLUGIN_ENABLED(stn)
PLUGIN_ENABLED(tlsmbedtls)
+PLUGIN_ENABLED(tlsopenssl)
###############################################################################
# Dependency checks
@@ -306,6 +307,12 @@ AM_COND_IF([ENABLE_TLSMBEDTLS_PLUGIN],
], [])
])
+AM_COND_IF([WITH_LIBSSL], [],
+[
+ AC_MSG_WARN([openssl not enabled. Disabling tlsopenssl plugin])
+ enable_tlsopenssl_plugin=no
+ AM_CONDITIONAL(ENABLE_TLSOPENSSL_PLUGIN, false)
+])
###############################################################################
# JAVA