aboutsummaryrefslogtreecommitdiffstats
path: root/src/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'src/configure.ac')
-rw-r--r--src/configure.ac6
1 files changed, 2 insertions, 4 deletions
diff --git a/src/configure.ac b/src/configure.ac
index eb380d8bf20..b2234448db7 100644
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -101,8 +101,7 @@ WITH_ARG(dpdk_crypto, [Use DPDK cryptodev])
WITH_ARG(dpdk_mlx5_pmd, [Use DPDK with mlx5 PMD])
# --without-X
-WITHOUT_ARG(ipsec, [Disable IPSec])
-WITHOUT_ARG(ipv6sr, [Disable IPv6 SR])
+WITHOUT_ARG(libssl, [Disable libssl])
WITHOUT_ARG(apicli, [Disable binary api CLI])
AC_ARG_WITH(unix,
@@ -133,8 +132,7 @@ AC_SUBST(APICLI, [-DVPP_API_TEST_BUILTIN=${n_with_apicli}])
AC_DEFINE_UNQUOTED(DPDK, [${n_with_dpdk}])
AC_DEFINE_UNQUOTED(DPDK_SHARED_LIB, [${n_enable_dpdk_shared}])
AC_DEFINE_UNQUOTED(DPDK_CRYPTO, [${n_with_dpdk_crypto}])
-AC_DEFINE_UNQUOTED(IPSEC, [${n_with_ipsec}])
-AC_DEFINE_UNQUOTED(IPV6SR, [${n_with_ipv6sr}])
+AC_DEFINE_UNQUOTED(WITH_LIBSSL, [${n_with_libssl}])
# Silence following noise: