summaryrefslogtreecommitdiffstats
path: root/src/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'src/configure.ac')
-rw-r--r--src/configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/src/configure.ac b/src/configure.ac
index d2fd5814619..bfd59372084 100644
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -217,6 +217,7 @@ PLUGIN_ENABLED(ioam)
PLUGIN_ENABLED(ixge)
PLUGIN_ENABLED(kubeproxy)
PLUGIN_ENABLED(lb)
+PLUGIN_ENABLED(marvell)
PLUGIN_ENABLED(memif)
PLUGIN_ENABLED(pppoe)
PLUGIN_ENABLED(sixrd)
@@ -291,6 +292,17 @@ AM_COND_IF([ENABLE_G2],
PKG_CHECK_MODULES(g2, gtk+-2.0)
])
+AM_COND_IF([ENABLE_MARVELL_PLUGIN],
+[
+ AC_CHECK_LIB( [musdk], [pp2_init],
+ [],
+ [
+ AC_MSG_WARN([Marvell MUSDK library with PP2 support not found. Plugin disabled.])
+ enable_marvell_plugin=no
+ AM_CONDITIONAL(ENABLE_MARVELL_PLUGIN, false)
+ ])
+])
+
# If cross-compiling, we need external vppapigen and we cannot continue without it
# For native builds, we just set dependency on vpppaigen binary in top_builddir
AM_COND_IF([CROSSCOMPILE],