summaryrefslogtreecommitdiffstats
path: root/src/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'src/configure.ac')
-rw-r--r--src/configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/src/configure.ac b/src/configure.ac
index 8b79cff224f..ee4985b5471 100644
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -161,6 +161,17 @@ AC_ARG_WITH(pre-data,
esac], [with_pre_data=128])
###############################################################################
+# Target CPU flags
+###############################################################################
+
+AS_CASE([$build_cpu],
+ [x86_64], [CPU_FLAGS="-march=corei7 -mtune=corei7-avx"],
+ [aarch64], [CPU_FLAGS="-march=armv8-a+crc"],
+ [CPU_FLAGS=""],
+)
+AC_SUBST([CPU_FLAGS])
+
+###############################################################################
# Substitutions and defines
###############################################################################