summaryrefslogtreecommitdiffstats
path: root/src/examples/sample-plugin/sample/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/examples/sample-plugin/sample/CMakeLists.txt')
-rw-r--r--src/examples/sample-plugin/sample/CMakeLists.txt32
1 files changed, 32 insertions, 0 deletions
diff --git a/src/examples/sample-plugin/sample/CMakeLists.txt b/src/examples/sample-plugin/sample/CMakeLists.txt
new file mode 100644
index 00000000000..f2fc1434492
--- /dev/null
+++ b/src/examples/sample-plugin/sample/CMakeLists.txt
@@ -0,0 +1,32 @@
+# Copyright (c) 2018 Cisco and/or its affiliates.
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+include_directories(${CMAKE_SOURCE_DIR})
+
+# for generated API headers:
+include_directories(${CMAKE_BINARY_DIR})
+
+add_vpp_plugin(sample
+ SOURCES
+ node.c
+ sample.c
+
+ MULTIARCH_SOURCES
+ node.c
+
+ API_FILES
+ sample.api
+
+ API_TEST_SOURCES
+ sample_test.c
+)