aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/acl/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/acl/CMakeLists.txt')
-rw-r--r--src/plugins/acl/CMakeLists.txt21
1 files changed, 21 insertions, 0 deletions
diff --git a/src/plugins/acl/CMakeLists.txt b/src/plugins/acl/CMakeLists.txt
new file mode 100644
index 00000000000..2040522affd
--- /dev/null
+++ b/src/plugins/acl/CMakeLists.txt
@@ -0,0 +1,21 @@
+# Copyright (c) 2018 Cisco and/or its affiliates.
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+add_vpp_plugin(acl_plugin
+ acl.api
+ acl.c
+ hash_lookup.c
+ lookup_context.c
+ sess_mgmt_node.c
+ dataplane_node.c
+)