aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/ikev2/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/ikev2/CMakeLists.txt')
-rw-r--r--src/plugins/ikev2/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/src/plugins/ikev2/CMakeLists.txt b/src/plugins/ikev2/CMakeLists.txt
index 13297c6dbac..dac2465241b 100644
--- a/src/plugins/ikev2/CMakeLists.txt
+++ b/src/plugins/ikev2/CMakeLists.txt
@@ -11,6 +11,9 @@
# See the License for the specific language governing permissions and
# limitations under the License.
+add_definitions (-DWITH_LIBSSL=1)
+include_directories(${OPENSSL_INCLUDE_DIR})
+
add_vpp_plugin(ikev2
SOURCES
ikev2.c
@@ -29,4 +32,7 @@ add_vpp_plugin(ikev2
INSTALL_HEADERS
ikev2.h
ikev2_priv.h
+
+ LINK_LIBRARIES
+ ${OPENSSL_LIBRARIES}
)