aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/lb/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/lb/CMakeLists.txt')
-rw-r--r--src/plugins/lb/CMakeLists.txt27
1 files changed, 27 insertions, 0 deletions
diff --git a/src/plugins/lb/CMakeLists.txt b/src/plugins/lb/CMakeLists.txt
new file mode 100644
index 00000000000..4df9dae4a08
--- /dev/null
+++ b/src/plugins/lb/CMakeLists.txt
@@ -0,0 +1,27 @@
+# Copyright (c) 2018 Cisco and/or its affiliates.
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+add_vpp_plugin(lb_plugin
+ lb.api
+ api.c
+ cli.c
+ lb.c
+ node.c
+ util.c
+)
+
+add_vpp_api_test_plugin(lb_test_plugin
+ lb.api
+ lb_test.c
+)
+