summaryrefslogtreecommitdiffstats
path: root/src/plugins/mactime/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/mactime/CMakeLists.txt')
-rw-r--r--src/plugins/mactime/CMakeLists.txt18
1 files changed, 18 insertions, 0 deletions
diff --git a/src/plugins/mactime/CMakeLists.txt b/src/plugins/mactime/CMakeLists.txt
index ac5077d1860..5477674f22a 100644
--- a/src/plugins/mactime/CMakeLists.txt
+++ b/src/plugins/mactime/CMakeLists.txt
@@ -22,3 +22,21 @@ add_vpp_plugin(mactime
API_TEST_SOURCES
mactime_test.c
)
+
+option(VPP_BUILD_MACTIME_TOP "Build mactime plugin 'top' tool" OFF)
+if(VPP_BUILD_MACTIME_TOP)
+ add_vpp_executable(mactime_top ENABLE_EXPORTS
+ SOURCES
+ mactime_top.c
+
+ DEPENDS api_headers
+
+ LINK_LIBRARIES
+ vlibmemoryclient
+ vppapiclient
+ svm
+ vppinfra
+ Threads::Threads
+ rt m dl crypto
+ )
+endif()